May 6, 2009
visibility 8051
star star star star star
(0 votes)

Solving The Issue :Failed to load some types from "EPiServer.Blog_Accessor”

 

This post is to solve an issue in the integration of EPiServer CMS5 R2 SP1 And Visual Studio .When you create a new EPiServer  project in Visual Studio 2008 and you don’t have VS Team Test  installed on your machine ,you might get an error message like this as and when you run the application :-

“

Message:-

Failed to load some types from "EPiServer.Blog_Accessor": Could not load file or assembly 'Microsoft.VisualStudio.QualityTools.UnitTestFramework, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: EPiServer.PlugIn.PlugInException: Failed to load some types from "EPiServer.Blog_Accessor": Could not load file or assembly 'Microsoft.VisualStudio.QualityTools.UnitTestFramework, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

”

This one had me baffled for a while.Thanks to Mr.Allan Thræn for getting this problem solved. It is actually a problem in the EPiServer CMS5 R2 SP1 And Visual Studio Integration, where an internal test dll (EPiServer.Blog_Accessor.dll) by accident has been included. That dll requires VS Team Test and if you don't have that installed you'll see the error above.

Solution:- The solution is easy, just delete the EPiServer.Blog_Accessor from your bin folder / remove it from your project.

May 06, 2009

Comments

Sep 21, 2010 10:32 AM

Solving The Issue :Failed to load some types from "EPiServer.Blog_Accessor”
Oru blog vachu erikunnuuu.... poyi padichu pani edukadaaaaaaaa
/ Nishar

error Please login to comment.
Latest blogs
Optimizely Agent Platform - October 2026 State of Play

Overview A month ago I wrote up my takeaways from Opticon New York ( Opticon New York & The Strategy on Upgrading to CMS 13 & Commerce 15 ). The...

Scott Reed | Oct 5, 2026

Migrating from Search & Navigation (Find) to Optimizely Graph in CMS 13

If you are planning an upgrade to Optimizely CMS 13, one of the biggest

Adnan Zameer | Oct 5, 2026 |

So you've decided to move to .NET 10 (but stay on CMS 12)

Ok, "decided" is a strong word. Microsoft decided for us. .NET 8 and .NET 9 both reach end of support on November 10, 2026 , and if you're on CMS 1...

KennyG | Oct 2, 2026

From robots.txt to GEO Analytics: A Year On

In September 2025, I wrote about updating

Adnan Zameer | Oct 2, 2026 |